Configurando el IDE Arduino

De Wikiversidad
Saltar a: navegación, buscar

En esta sección aprenderás a configurar el IDE (interfaz) Arduino (versión 0022) en tu computadora. Esta actividad está pensada para sistemas operativos GNU/Linux (en especial Debian Squeeze).

Obteniendo el Software de Arduino[editar]

Descarga el software de http://arduino.googlecode.com/files/arduino-0022.tgz (versión 32-bits) o http://arduino.googlecode.com/files/arduino-0022-64-2.tgz (versión 64-bits)

Descompresión[editar]

Utilizando un programa de descompresión (por ejemplo File Roller) extrae la carpeta "arduino-0022" a tu escritorio (o a la carpeta de tu elección)

Lanza la interfaz[editar]

Conecta tu Arduino a través del cable USB y abre la carpeta "arduino-0022" y ejecuta el archivo "arduino". Verás una interfaz como esta:

La interfaz de desarrollo Arduino

Si no logras ejecutar el archivo prueba correrlo desde una terminal yendo a la carpeta arduino-0022 utilizando el comando "cd algunaCarpeta/arduino-0022" donde algunCarpeta representa el lugar donde extrajiste el folder arduino-0022. Posteriormente ejecuta el comando ./arduino Si aún no logras correrlo asegurate de tener instaladas las dependencias (los paquetes openjdk, librxtx-java, gcc-avr, avr-libc y avrdude).

Escoje tu modelo de placa[editar]

Del menú "tools" escoje la opción "board" y de la lista elije el modelo de placa Arduino que tienes.

Tools->Board

Elije tu puerto Serial[editar]

Del menú "tools" escoje la opción "Serial Port" y de la lista elije tu puerto serial, lo mas probable es que sólo haya una opción parecida a "/dev/ttyACM0"

Tools->SerialPort

Prueba la configuración[editar]

Para probar la configuración ve al menú "File->examples->basic->blink" y presiona el botón "Upload" (cargar) marcado por una flecha que apunta a la derecha hacia unos puntos.Verás que en el estado dirá "Done Uploading" y que un LED amarillo parpadea en tu placa.

"File->examples->basic->blink"
Barra de herramientas Arduino

Fallas Comunes[editar]

No puedo lanzar la interfaz[editar]

Revisa que tengas todas las dependencias instaladas (los paquetes openjdk, librxtx-java, gcc-avr, avr-libc y avrdude). Prueba correr el archivo arduino desde una terminal yendo a la carpeta arduino-0022 utilizando el comando "cd algunaCarpeta/arduino-0022" donde algunaCarpeta representa el lugar donde extrajiste el folder arduino-0022. Posteriormente ejecuta el comando ./arduino. El output de la terminal te dará más información sobre tu error.

No encuentro mi modelo de Arduino en el menú Tools->Board[editar]

Asegurate de estar usando la versión 0022 del software arduino, las versiones anteriores no incluyen las placas más nuevas (como la UNO).

El menú Tools->SerialPort aparece en gris y no lo puedo seleccionar[editar]

Cierra la interfaz, desconecta y vuelve a conectar tu Arduino y vuelve a intentar. Si esto no funciona intenta abrir Arduino como administrador usando el comando "sudo ./arduino" desde una terminal.